Setup: gli_gl_b-1300

Written By Aaron Low (Administrator)

Updated at July 27th, 2024

Flashing Instructions

https://git.openwrt.org/?p=openwrt/openwrt.git;a=commit;h=04d3308b6248ef21a6f0bc3378b342906c2d2865


Installation: 


Method 1: 
- use serial port to stop uboot 
- uboot command: run lf 


Method 2:
- push down reset button and power on
- wait until three leds constantly on then release
- upgrade by uboot web at http://192.168.1.1


Note: 
- the sysupgrade image need to be renamed to lede-gl-b1300.bin in both methods. 
- the sysupgrade image can be automatically downloaded if tftp server at 192.168.1.2 have that file.
- the wifi led will be flashing when writing image.

Web flash flash from U-Boot

Push down reset button and power on Wait until two LEDs are constantly on, then release reset button (~30 seconds). 
Upgrade through the uboot web interface at http://192.168.1.1

Note: The sysupgrade image needs to be renamed to lede-gl-b1300.bin the wifi led will be flashing when writing image.

Vanilla LEDE/Openwrt 17.x Files

/etc/config/wireless 

config wifi-device 'radio0' 
  option type 'mac80211' 
  option channel '11' 
  option hwmode '11g' 
  option path 'platform/soc/a000000.wifi' 
  option htmode 'HT20'
  option disabled '1'

config wifi-iface 'default_radio0' 
  option device 'radio0' 
  option network 'lan' 
  option mode 'ap' 
  option ssid 'OpenWrt' 
  option encryption 'none'

config wifi-device 'radio1' 
  option type 'mac80211' 
  option channel '36' 
  option hwmode '11a' 
  option path 'platform/soc/a800000.wifi' 
  option htmode 'VHT80' 
  option disabled '1'

config wifi-iface 'default_radio1' 
  option device 'radio1' 
  option network 'lan' 
  option mode 'ap' 
  option ssid 'OpenWrt' 
  option encryption 'none'

/etc/config/network

config interface 'loopback' 
  option ifname 'lo' 
  option proto 'static' 
  option ipaddr '127.0.0.1' 
  option netmask '255.0.0.0'

config globals 'globals' 
  option ula_prefix 'fde2:c64e:528b::/48'

config interface 'lan' 
  option type 'bridge' 
  option ifname 'eth0' 
  option proto 'static' 
  option ipaddr '192.168.1.1' 
  option netmask '255.255.255.0' 
  option ip6assign '60'

config interface 'wan' 
  option ifname 'eth1' 
  option proto 'dhcp'

config interface 'wan6' 
  option ifname 'eth1' 
  option proto 'dhcpv6'

config switch 
  option name 'switch0' 
  option reset '1' 
  option enable_vlan '1'

config switch_vlan 
  option device 'switch0' 
  option vlan '1' 
  option ports '3 4 0'

 

/etc/config/system 

config system 
  option hostname 'OpenWrt' 
  option timezone 'UTC' 
  option ttylogin '0' 
  option logsize '64' 
  option urandomseed '0'

config timeserver 'ntp' 
  option enabled '1' 
  option enable_server '0' 
  list server '0.openwrt.pool.ntp.org' 
  list server '1.openwrt.pool.ntp.org' 
  list server '2.openwrt.pool.ntp.org' 
  list server '3.openwrt.pool.ntp.org'

config led 'led_wlan' 
  option name 'WLAN' 
  option sysfs 'gl-b1300:green:wlan' 
  option trigger 'phy0tpt'